Bigleaf Support Line Issues

Incident Report for Bigleaf Networks

Resolved

Our phone service provider has resolved the issue and inbound call service is functioning normally. We apologize for any inconvenience.
Posted May 20, 2024 - 15:05 PDT

Investigating

We are experiencing some issues with our phone system provider that may cause difficulty in contacting Bigleaf Technical Support. Inbound calls to our main phone numbers at (888) 244-3133 and (503) 985-8298 may be affected.

If you are experiencing this, please email our Support team at support@bigleaf.net. Our team is monitoring the emails, ticket requests, and voicemails. If you are experiencing an urgent issue please contact us immediately via email and we will contact you as soon as possible.

Future updates will be posted here.

Thanks for your patience!
Posted May 20, 2024 - 13:32 PDT
This incident affected: Other.