Bigleaf Support Line Issues

Incident Report for Bigleaf Networks

Resolved

This incident has been resolved
Posted 1 year ago. Apr 24, 2024 - 06:47 PDT

Identified

We are currently investigating and working to resolve an issue with reaching our Support team via our (888) 244-3133 phone line as well as impacting emails to support@bigleaf.net
Posted 1 year ago. Apr 24, 2024 - 05:42 PDT

Investigating

We are currently investigating an issue with reaching our Support team via our (888) 244-3133 phone line
Posted 1 year ago. Apr 24, 2024 - 05:30 PDT
This incident affected: Other.