Network Performance Issues - Frankfurt, DE

Incident Report for Bigleaf Networks

Resolved

This incident has been resolved.
Posted May 28, 2025 - 11:08 PDT

Investigating

We are currently investigating network congestion issues that are impacting a subset of sites connected to our Frankfurt gateway cluster.
Posted May 28, 2025 - 07:07 PDT
This incident affected: Gateway Cluster: Frankfurt, DE.