Bigleaf technical support phone provider issues
Incident Report for Bigleaf Networks
Resolved
The incident occurring with our phone system provider has been resolved. Calls to our main phone numbers at (888) 244-3133 and (503) 985-8298 are operating as expected. We will be monitoring in order to ensure stability.

The Bigleaf Support line is available for you at this time.

Thank you again.
Posted Apr 15, 2021 - 14:22 PDT
Identified
We are experiencing some issues with our phone system provider that may cause difficulty in contacting Bigleaf Technical Support. Inbound calls to our main phone numbers at (888) 244-3133 and (503) 985-8298 may be affected.

If you are experiencing this, please email our Support team at support@bigleaf.net. Our team is monitoring the emails, ticket requests, and voicemails. If you are experiencing an urgent issue please contact us immediately via email and we will contact you as soon as possible.

Future updates will be posted here.

Thanks for your patience!
Posted Apr 15, 2021 - 13:40 PDT
This incident affected: Other.